CPAN->GREP


1 to 25 of more than 1000 distributions (3.32 seconds)
UI-Dialog-1.09-2/UI-Dialog-1.09/lib/UI/Dialog.pm
				$self->_debug("trying zenity",2);
				if (eval "require UI::Dialog::Backend::Zenity; 1" && $self->_has_variant('zenity')) {
					require UI::Dialog::Backend::Zenity;
#: In Debian, gdialog is now being diverted to gdialog.real as zenity is the gnome2 replacement
				if (eval "require UI::Dialog::Backend::GDialog; 1" && ($self->_has_variant('gdialog.real') ||
																	   $self->_has_variant('gdialog'))) {
				$self->_debug("trying xdialog",2);
				if (eval "require UI::Dialog::Backend::XDialog; 1" && $self->_has_variant('Xdialog')) {
					require UI::Dialog::Backend::XDialog;
8 more matches »
KCK/UI-Dialog-1.09-2 5 more files »
Module-Install-1.08/inc/Module/Install/Metadata.pm
		# XXX: ugly but should work anyway...
		if (eval "require Pod::Escapes; 1") {
			# Pod::Escapes has a mapping table.
		}
		elsif (eval "require Pod::Text; 1" && $Pod::Text::VERSION < 3) {
			# Pod::Text < 3.0 has yet another mapping table,
BINGOS/Module-Install-1.08 2 more files »
perl-5.18.2/cpan/Module-Build/lib/Module/Build/Compat.pm
    my (%MM_Args, %prereq);
    if (eval "use Tie::IxHash 1.2; 1") {
      tie %MM_Args, 'Tie::IxHash'; # Don't care if it fails here
RJBS/perl-5.18.2 2 more files »
GBrowse-2.55/install_util/GBrowseInstall.pm
    my $self = shift;
    if (eval "require DBD::SQLite; 1") {
	my $databases = $self->config_data('databases');
	return "DBI:SQLite:$databases/users.sqlite";
    } elsif (eval "require DBD::mysql; 1") {
	return 'DBI:mysql:gbrowse_login;user=gbrowse;password=gbrowse';
LDS/GBrowse-2.55 2 more files »
LWP-UserAgent-DNS-Hosts-0.08/inc/Module/Install/Metadata.pm
		# XXX: ugly but should work anyway...
		if (eval "require Pod::Escapes; 1") {
			# Pod::Escapes has a mapping table.
		}
		elsif (eval "require Pod::Text; 1" && $Pod::Text::VERSION < 3) {
			# Pod::Text < 3.0 has yet another mapping table,
MASAKI/LWP-UserAgent-DNS-Hosts-0.08 2 more files »
Gearman-Spawner-1.11/t/04-sync-client.t
if (eval "use Gearman::Spawner::Client::Sync; 1") {
    plan tests => 15;
ATHOMASON/Gearman-Spawner-1.11 3 more files »
IO-Callback-HTTP-0.002/inc/Module/Install/Metadata.pm
		# XXX: ugly but should work anyway...
		if (eval "require Pod::Escapes; 1") {
			# Pod::Escapes has a mapping table.
		}
		elsif (eval "require Pod::Text; 1" && $Pod::Text::VERSION < 3) {
			# Pod::Text < 3.0 has yet another mapping table,
TOBYINK/IO-Callback-HTTP-0.002 2 more files »
Storable-2.45/t/downgrade.t
if (eval "use Hash::Util; 1") {
  print "# We have Hash::Util, so test that the restricted hashes in <DATA> are valid\n";
  }
  if (eval "use Hash::Util; 1") {
    print "# We have Hash::Util, so test that the restricted utf8 hash is valid\n";
  #foreach (keys %$got) { print "'$_':\t'$got->{$_}'\n"; }
  if (eval "use Hash::Util; 1") {
    print "# We have Hash::Util, so test that the restricted hashes in <DATA> are valid\n";
AMS/Storable-2.45
MarpaX-Languages-C-AST-0.37/examples/h2xs.PL
     print EX <<_END_;
  next if (eval "my \\\$a = \$constname; 1");
  if (\$\@ =~ /^Your vendor has not defined $module macro \$constname/) {
     print EX <<_END_;
  next if (eval "my \\\$a = \$constname; 1");
  if (\$\@ =~ /^Your vendor has not defined $module macro \$constname/) {
JDDPAUSE/MarpaX-Languages-C-AST-0.37 1 more file »
jmx4perl-1.07/inc/Module-Build/Module/Build/Base.pm
      my $class = "Software::License::$key";
      if (eval "use $class; 1") {
        # S::L requires a 'holder' key
ROLAND/jmx4perl-1.07 2 more files »
XML-TinyXML-0.34/lib/XML/TinyXML/Selector.pm
    my $module = __PACKAGE__ . "::" . $type;
    if (eval "require $module; 1") {
        my $self = {};
XANT/XML-TinyXML-0.34 2 more files »
Win32-Mock-0.05/lib/Win32/Mock/Win32.pm
    if (eval "use Data::GUID; 1") {
        $guid = "{" . eval { Data::GUID->new } ."}"
    }
    elsif (eval "use Win32::Guidgen; 1") {
        $guid = eval { Win32::Guidgen::create() }
sub Sleep {
    if (eval "use Time::HiRes; 1") {
        usleep($_[0] * 1000)
SAPER/Win32-Mock-0.05
PBS-0.03/Attr/t/Attr.t
	SHUT_DELAY SHUT_IMMEDIATE SHUT_QUICK SHUT_SIG)) {
  next if (eval "my \$a = $constname; 1");
  if ($@ =~ /^Your vendor has not defined PBS macro $constname/) {
TMERRITT/PBS-0.03 2 more files »
Err-0.02/inc/Module/Install/Metadata.pm
		# XXX: ugly but should work anyway...
		if (eval "require Pod::Escapes; 1") {
			# Pod::Escapes has a mapping table.
		}
		elsif (eval "require Pod::Text; 1" && $Pod::Text::VERSION < 3) {
			# Pod::Text < 3.0 has yet another mapping table,
MARKF/Err-0.02 1 more file »
Net-DBus-1.0.0/t/00-constants.t
        SYSTEM SESSION STARTER)) {
  next if (eval "my \$a = &Net::DBus::Binding::Bus::$constname; 1");
  print "# fail: $@";
	TYPE_STRING TYPE_UINT32 TYPE_UINT64)) {
  next if (eval "my \$a = &Net::DBus::Binding::Message::$constname; 1");
  print "# fail: $@";
        ERROR HANGUP)) {
  next if (eval "my \$a = &Net::DBus::Binding::Watch::$constname; 1");
  print "# fail: $@";
DANBERR/Net-DBus-1.0.0
Minilla-v0.11.1/lib/Minilla/CLI/Release.pm
        my $klass = "Minilla::Release::$_";
        if (eval "require ${klass}; 1") {
            push @klasses, $klass;
TOKUHIROM/Minilla-v0.11.1 2 more files »
Email-Address-Loose-0.10/inc/Module/Install/Metadata.pm
		# XXX: ugly but should work anyway...
		if (eval "require Pod::Escapes; 1") {
			# Pod::Escapes has a mapping table.
		}
		elsif (eval "require Pod::Text; 1" && $Pod::Text::VERSION < 3) {
			# Pod::Text < 3.0 has yet another mapping table,
TOMITA/Email-Address-Loose-0.10 1 more file »
Lua-API-0.04/inc/Module/Install/Metadata.pm
		# XXX: ugly but should work anyway...
		if (eval "require Pod::Escapes; 1") {
			# Pod::Escapes has a mapping table.
		}
		elsif (eval "require Pod::Text; 1" && $Pod::Text::VERSION < 3) {
			# Pod::Text < 3.0 has yet another mapping table,
DJERIUS/Lua-API-0.04 1 more file »
Pod-Inherit-0.90/inc/Module/Install/Metadata.pm
		# XXX: ugly but should work anyway...
		if (eval "require Pod::Escapes; 1") {
			# Pod::Escapes has a mapping table.
		}
		elsif (eval "require Pod::Text; 1" && $Pod::Text::VERSION < 3) {
			# Pod::Text < 3.0 has yet another mapping table,
BBYRD/Pod-Inherit-0.90 1 more file »
Acme-Ikamusume-0.07/inc/Module/Install/Metadata.pm
		# XXX: ugly but should work anyway...
		if (eval "require Pod::Escapes; 1") {
			# Pod::Escapes has a mapping table.
		}
		elsif (eval "require Pod::Text; 1" && $Pod::Text::VERSION < 3) {
			# Pod::Text < 3.0 has yet another mapping table,
TOMITA/Acme-Ikamusume-0.07
WebService-Pushwoosh-0.02/inc/Module/Install/Metadata.pm
		# XXX: ugly but should work anyway...
		if (eval "require Pod::Escapes; 1") {
			# Pod::Escapes has a mapping table.
		}
		elsif (eval "require Pod::Text; 1" && $Pod::Text::VERSION < 3) {
			# Pod::Text < 3.0 has yet another mapping table,
MCARTMELL/WebService-Pushwoosh-0.02
Catalyst-Plugin-I18N-PathPrefix-0.07/inc/Module/Install/Metadata.pm
		# XXX: ugly but should work anyway...
		if (eval "require Pod::Escapes; 1") {
			# Pod::Escapes has a mapping table.
		}
		elsif (eval "require Pod::Text; 1" && $Pod::Text::VERSION < 3) {
			# Pod::Text < 3.0 has yet another mapping table,
MENDEL/Catalyst-Plugin-I18N-PathPrefix-0.07
RT-Extension-MandatoryFields-0.6/inc/Module/Install/Metadata.pm
		# XXX: ugly but should work anyway...
		if (eval "require Pod::Escapes; 1") {
			# Pod::Escapes has a mapping table.
		}
		elsif (eval "require Pod::Text; 1" && $Pod::Text::VERSION < 3) {
			# Pod::Text < 3.0 has yet another mapping table,
BHEISIG/RT-Extension-MandatoryFields-0.6
ORDB-CPANRT-0.04/inc/Module/Install/Metadata.pm
		# XXX: ugly but should work anyway...
		if (eval "require Pod::Escapes; 1") {
			# Pod::Escapes has a mapping table.
		}
		elsif (eval "require Pod::Text; 1" && $Pod::Text::VERSION < 3) {
			# Pod::Text < 3.0 has yet another mapping table,
ADAMK/ORDB-CPANRT-0.04
DBIx-Class-Fixtures-1.001021/inc/Module/Install/Metadata.pm
		# XXX: ugly but should work anyway...
		if (eval "require Pod::Escapes; 1") {
			# Pod::Escapes has a mapping table.
		}
		elsif (eval "require Pod::Text; 1" && $Pod::Text::VERSION < 3) {
			# Pod::Text < 3.0 has yet another mapping table,
JJNAPIORK/DBIx-Class-Fixtures-1.001021
Home · About